“白屏保护模式”将是WordPress 5.1最重要的新特性,Beta 1版本已可供测试

WordPress 5.0.3已经在本周被推送,带来了有关块编辑器BUG的修复。后台自动升级已经推出。并且,据统计,23.2% WordPress正在使用WordPress 5.0及以上的版本,47.2%的WordPress网站正在使用4.9版本。与此同时,完善WordPress 5.1的工作正在进行中,Beta 1版本现在已可供下载与试用。

据WP TAVERN介绍 ,WordPress 5.0.3已经在本周被推送,带来了有关块编辑器BUG的修复。后台自动升级已经推出。并且,据统计,23.2% WordPress正在使用WordPress 5.0及以上的版本,47.2%的WordPress网站正在使用4.9版本。与此同时,完善WordPress 5.1的工作正在进行中,Beta 1版本现在已可供下载与试用。

将Site Health Check插件整合进WordPress的内核以更好地帮助站长们debug和鼓励“良好的软件卫生(hygiene)”是Matt Mullenweg(WordPress创始人)定位的2019的项目之一。之前被称作“ServeHappy”的整合Site Health Check的项目最初因为为了帮助站长们在被支持的PHP版本上运行他们的站点,然而这个项目逐渐也囊括了诸如帮助站长维护网站和排除BUG。

而WordPress 5.1则将这一项目最重要的一个功能带入了内核。5.1版本带来了新的一个名叫“白屏保护(WSOD)”的功能。这个功能可以帮助“抓取”致命的错误,从而使用户们依然可以登陆到后台里面并且尝试解决这些致命问题。在过去,如果站长们不懂技术的话,那么他们必须联系主机提供商,或者使用FTP与他们的站点取得联系,然后尝试解决这些BUG。

与此同时,WordPress对计划中的“最低PHP版本升级”做出了准备。5.1版本将会对低于未来预期的最低PHP版本的用户提出警告,并且帮助他们升级PHP版本。在今年四月份的时候,WordPress要求的最低PHP版本将会变成5.6。之后用户的反馈将决定WordPress要求的最低PHP版本是否会在2019年12月上升到7.0版本。

援引自一名名叫Jenny Wong的WordPress工作者在WCUS 2018年上的观点。她认为,这一项目的目的不仅使WordPress用户受惠,更是对围绕PHP生态系统大有裨益。WordPress希望这一项目能够尽可能地推动PHP的更新换代。

如果你想体验Site Health Check插件的更多功能,不妨在WordPress.org上面直接下载安装,随后在插件页面就可以看到有关站点的详细数据。这款插件也支持“香草模式”,即所有插件都失效,并且使用默认主题的模式(可以理解成以一个新站点的配置来进行问题排查)。最重要的是,使用了这款插件之后,所有为了排查而做出的举动,都不会被访客们看见。

注:

英文原版报道来自WP TAVERN:WordPress 5.1 to Introduce New White Screen Protection Feature, Beta 1 Now Available for Testing

发表评论

电子邮件地址不会被公开。 必填项已用*标注